aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-parametrize-from-file/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-parametrize-from-file/APKBUILD')
-rw-r--r--community/py3-parametrize-from-file/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/py3-parametrize-from-file/APKBUILD b/community/py3-parametrize-from-file/APKBUILD
index 5fa241c540b..9b0342b7f02 100644
--- a/community/py3-parametrize-from-file/APKBUILD
+++ b/community/py3-parametrize-from-file/APKBUILD
@@ -1,36 +1,39 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-parametrize-from-file
-pkgver=0.7.1
-pkgrel=0
+pkgver=0.19.0
+pkgrel=1
pkgdesc="Parametrize From File"
url="https://parametrize-from-file.readthedocs.io/en/latest/"
arch="noarch"
license="MIT"
depends="
+ python3>=3.6
py3-toml
py3-yaml
py3-nestedtext
py3-tidyexc
- py3-more-itertools
- py3-contextlib2
+ py3-more-itertools>=8.10
py3-decopatch
- py3-voluptuous
"
makedepends="
- py3-setuptools
- pyproject2setuppy
+ py3-flit-core
+ py3-gpep517
"
checkdepends="
py3-pytest
- py3-voluptuous
+ py3-pytest-cov
+ py3-coveralls
py3-numpy
"
-source="https://files.pythonhosted.org/packages/source/p/parametrize_from_file/parametrize_from_file-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://github.com/kalekundert/parametrize_from_file/archive/v$pkgver/parametrize_from_file-v$pkgver.tar.gz"
builddir="$srcdir/parametrize_from_file-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -38,9 +41,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/parametrize_from_file*.whl
}
sha512sums="
-6183dba7f15d6cb05221ca77c61022ed016a58072ed5bd2dd934c5994c820602605380281b5a6535f76dfb82967ca6612309121e628b4d99458f95595b6826ad parametrize_from_file-0.7.1.tar.gz
+0fd468aa19cf9a9cc9be17893ad75d31facf7d8d43227aac2e007c17daf4fcb2c239a3493ddc025c8c639dbba2fe5fc351117755ea1b7173435172c9d3f1f910 parametrize_from_file-v0.19.0.tar.gz
"