aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-parso/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-parso/APKBUILD')
-rw-r--r--community/py3-parso/APKBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/community/py3-parso/APKBUILD b/community/py3-parso/APKBUILD
index db81218d0eb..07162089429 100644
--- a/community/py3-parso/APKBUILD
+++ b/community/py3-parso/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-parso
-pkgver=0.6.1
-pkgrel=0
-pkgdesc="Python3 parser that supports error recovery and round-trip parsing for different Python versions"
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="parser that supports error recovery and round-trip parsing for different Python versions"
url="https://github.com/davidhalter/parso"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/parso/parso-$pkgver.tar.gz"
builddir="$srcdir/parso-$pkgver"
@@ -17,15 +18,24 @@ replaces="py-parso" # Backwards compatibility
provides="py-parso=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- py.test-3
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # python 3.12 errors: https://github.com/davidhalter/parso/issues/222
+ .testenv/bin/python3 -m pytest \
+ --deselect test/test_python_errors.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="6c7043f1fc8a05e176794e0e7b114b22b333d9d7eb8121d34e9767124c153f663cd8a8be4b02799eac31c2d502971167d1df6dd465b306131c4cc63d05626f96 parso-0.6.1.tar.gz"
+sha512sums="
+bdc9860272d847fb839057c8e5d45864f290a4b2c0ea7cfa08886a9c0f1764f891bf633703c897a0f0c20102c4b258a75122c0d51066155e53f40b4daf728c0e parso-0.8.4.tar.gz
+"