aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-parso/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-parso/APKBUILD')
-rw-r--r--community/py3-parso/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/py3-parso/APKBUILD b/community/py3-parso/APKBUILD
index 508536c6f84..8b76e6c3271 100644
--- a/community/py3-parso/APKBUILD
+++ b/community/py3-parso/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-parso
-pkgver=0.7.0
-pkgrel=0
-pkgdesc="Python3 parser that supports error recovery and round-trip parsing for different Python versions"
+pkgver=0.8.3
+pkgrel=2
+pkgdesc="parser that supports error recovery and round-trip parsing for different Python versions"
url="https://github.com/davidhalter/parso"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools py3-pbr"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="
https://files.pythonhosted.org/packages/source/p/parso/parso-$pkgver.tar.gz
"
@@ -23,11 +24,15 @@ build() {
}
check() {
- py.test-3
+ # python 3.10 errors: https://github.com/davidhalter/parso/issues/192
+ py.test-3 -v \
+ --deselect test/test_python_errors.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="7ca6fbf001826afd57c9777bc5cc0d206b52c5c15b8f237ab4add041c2a7b9cf911a9959e1e9e24c5a00d46d447b0c66efd5381955201d7053933a97e32b8934 parso-0.7.0.tar.gz"
+sha512sums="
+6a8626b2aa254e8c3b5afbacd122085d5a69ea04aeb271141f284822e300e8f7f1a53f9dc483a6522fe309cf09f60624972bb666d3a82d06af808c6790f87f1d parso-0.8.3.tar.gz
+"