aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-partd
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-partd')
-rw-r--r--community/py3-partd/APKBUILD38
1 files changed, 29 insertions, 9 deletions
diff --git a/community/py3-partd/APKBUILD b/community/py3-partd/APKBUILD
index fa5aaa532ba..b6d8d57d718 100644
--- a/community/py3-partd/APKBUILD
+++ b/community/py3-partd/APKBUILD
@@ -1,28 +1,48 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-partd
-pkgver=1.1.0
-pkgrel=0
+pkgver=1.4.1
+pkgrel=2
pkgdesc="Concurrent appendable key-value storage"
url="https://github.com/dask/partd/"
-arch="noarch !mips !mips64 !s390x" # Blocked by py3-pyzmq
+arch="noarch"
license="BSD-3-Clause"
-depends="python3 py3-toolz py3-numpy py3-pyzmq py3-pandas py3-locket"
-makedepends="py3-setuptools"
+depends="
+ py3-locket
+ py3-numpy
+ py3-pandas
+ py3-pyzmq
+ py3-toolz
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ py3-python-versioneer
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/p/partd/partd-$pkgver.tar.gz"
options="!check" # No tests
builddir="$srcdir/partd-$pkgver"
build() {
- python3 setup.py build
+ rm versioneer.py
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="5e26c4a63fc2f9a290b211c1fce291da6b3354b4d0fdf941d29ddad1252629c94275ac360d33c88d11ff4e36a4f4d6bee42edd867c92eb7ef0d2697472c9a338 partd-1.1.0.tar.gz"
+sha512sums="
+0bf285a33731d3c000e6c2c1958cda0df21c3a2be31694ac31ce0cc45aa2b31b8631f962c25b9ecac3831474abb5872748bd3348f99e13faadee467a1f164492 partd-1.4.1.tar.gz
+"