aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-passlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-passlib/APKBUILD')
-rw-r--r--community/py3-passlib/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-passlib/APKBUILD b/community/py3-passlib/APKBUILD
index 054aba43053..faa2d8b5a46 100644
--- a/community/py3-passlib/APKBUILD
+++ b/community/py3-passlib/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-passlib
pkgver=1.7.4
-pkgrel=0
+pkgrel=5
pkgdesc="Password hashing library supporting over 30 schemes"
url="https://foss.heptapod.net/python-libs/passlib/wikis/home"
arch="noarch"
@@ -10,6 +10,7 @@ license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-nose py3-scrypt"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/passlib/passlib-$pkgver.tar.gz"
builddir="$srcdir"/passlib-$pkgver
@@ -25,7 +26,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530 passlib-1.7.4.tar.gz"