aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-paste/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-paste/APKBUILD')
-rw-r--r--community/py3-paste/APKBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/community/py3-paste/APKBUILD b/community/py3-paste/APKBUILD
index 5b489cc65ce..bb880757de0 100644
--- a/community/py3-paste/APKBUILD
+++ b/community/py3-paste/APKBUILD
@@ -1,29 +1,42 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-paste
-pkgver=3.5.0
+pkgver=3.9.0
pkgrel=1
pkgdesc="Tools for using a Web Server Gateway Interface stack"
url="https://pythonpaste.readthedocs.io/en/latest/"
arch="noarch"
license="MIT"
-depends="py3-setuptools py3-six"
+depends="
+ py3-setuptools
+ py3-six
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/P/Paste/Paste-$pkgver.tar.gz"
builddir="$srcdir/Paste-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -p no:warnings
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-a9f596d6fcd95f915990c16830caeb9c9a03412447597258c67a003fd485e2efd27798f2eb2de9978ac529292af4b55136de554bfb501e90f6185f55a6b0531b py3-paste-3.5.0.tar.gz
+a9099b89e17f597e853d82cc5d99aaf84fa71ee25e92a382a47a482982800a7e766d8389530ef2a7ad145771ebbabdb1ae5d8370d9cd30121b94e18bcaef3f81 py3-paste-3.9.0.tar.gz
"