aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-path/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-path/APKBUILD')
-rw-r--r--community/py3-path/APKBUILD43
1 files changed, 26 insertions, 17 deletions
diff --git a/community/py3-path/APKBUILD b/community/py3-path/APKBUILD
index bbb13a5c204..c0840807d01 100644
--- a/community/py3-path/APKBUILD
+++ b/community/py3-path/APKBUILD
@@ -1,36 +1,45 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-path
-pkgver=15.1.2
-pkgrel=3
+pkgver=16.10.0
+pkgrel=1
pkgdesc="Module wrapper for os.path"
url="https://github.com/jaraco/path"
arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
+depends=""
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="
+ py3-more-itertools
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
source="https://github.com/jaraco/path/archive/v$pkgver/path-v$pkgver.tar.gz"
builddir="$srcdir/path-$pkgver"
-prepare() {
- default_prepare
-
- sed -e '/setuptools_scm/d' \
- -e "/^\[metadata\]/a version = $pkgver" \
- -i setup.cfg
-}
-
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/path*.whl
}
-sha512sums="a555fae28c3edfeb0f1114a205373ae3e7278373b98820877acafee6e88f4fcdf7eb2da576eafb2123fc77305e90a58b4c1b11193e092d0a5a6d2a779099faf6 path-v15.1.2.tar.gz"
+sha512sums="
+9dc43085e92df7893c964ccf56c61e86b48c22fa8d8998da34a78af6b2b60e7774e1b0aa1b30752d01900109af91731e44a55773226dc95945ede8890f2c8095 path-v16.10.0.tar.gz
+"