aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-patiencediff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-patiencediff/APKBUILD')
-rw-r--r--community/py3-patiencediff/APKBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/community/py3-patiencediff/APKBUILD b/community/py3-patiencediff/APKBUILD
index 275b3f7d713..bb05e2adca0 100644
--- a/community/py3-patiencediff/APKBUILD
+++ b/community/py3-patiencediff/APKBUILD
@@ -1,28 +1,39 @@
# Maintainer: Pedro Filipe <xpecex@outlook.com>
pkgname=py3-patiencediff
-pkgver=0.2.2
-pkgrel=0
+pkgver=0.2.14
+pkgrel=1
pkgdesc="Patiencediff Python and C implementations"
url="https://www.breezy-vcs.org/"
arch="all"
license="GPL-2.0-or-later"
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/breezy-team/patiencediff/archive/v$pkgver.tar.gz"
builddir="$srcdir/patiencediff-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest discover
}
package() {
- python3 setup.py install --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-fb7c4db590b0a09b79314fd7cda255253dfeb9fa6158b58cbb1fce69bc81361823cb8cadca56fd93d22eee40af0778536e9402a029d0c133d269154c79ffb0c3 py3-patiencediff-0.2.2.tar.gz
+ce08633b275030318fc165393c4cc3694816a2d044c29b7412e26f029fac6fe6530a56f9f2910e6c843623363663fb11251f7d1cd024247a6fa7d1b617a55b2e py3-patiencediff-0.2.14.tar.gz
"