aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pcodedmp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pcodedmp/APKBUILD')
-rw-r--r--community/py3-pcodedmp/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-pcodedmp/APKBUILD b/community/py3-pcodedmp/APKBUILD
new file mode 100644
index 00000000000..f9482848a1a
--- /dev/null
+++ b/community/py3-pcodedmp/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-pcodedmp
+pkgver=1.2.6
+pkgrel=3
+pkgdesc="VBA p-code disassembler"
+url="https://github.com/bontchev/pcodedmp"
+arch="noarch"
+license="GPL-3.0-only"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/pcodedmp/pcodedmp-$pkgver.tar.gz"
+options="!check" #there are no tests
+builddir="$srcdir/pcodedmp-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+bb8fb874b4140b517731b0de29b9ca1858d310d28c29806d224f6df59988d6bf8934756e14a8a9d913c665c469b23179a5edd10256c179d06d60a2a9f48fcabd pcodedmp-1.2.6.tar.gz
+"