aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-platformdirs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-platformdirs/APKBUILD')
-rw-r--r--community/py3-platformdirs/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/py3-platformdirs/APKBUILD b/community/py3-platformdirs/APKBUILD
new file mode 100644
index 00000000000..6f1384199cd
--- /dev/null
+++ b/community/py3-platformdirs/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-platformdirs
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="Module for determining appropriate platform-specific dirs"
+url="https://github.com/platformdirs/platformdirs"
+arch="noarch"
+license="MIT"
+makedepends="py3-gpep517 py3-hatchling py3-hatch-vcs"
+checkdepends="py3-appdirs py3-pytest py3-pytest-mock"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz"
+builddir="$srcdir/platformdirs-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+615742163cc4eb0ee97c4dba069d59a08e0056e05a3fbeab32dcab854ed56976e8707dd70afd65dbd0732bf1ad1a42c565fb3d980b7b668aa2cdecc5cc1de4f0 platformdirs-4.2.0.tar.gz
+"