aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-platformdirs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-platformdirs/APKBUILD')
-rw-r--r--community/py3-platformdirs/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/py3-platformdirs/APKBUILD b/community/py3-platformdirs/APKBUILD
index 6b3aee8d0d6..375af93a34f 100644
--- a/community/py3-platformdirs/APKBUILD
+++ b/community/py3-platformdirs/APKBUILD
@@ -1,32 +1,34 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-platformdirs
-pkgver=2.3.0
-pkgrel=1
+pkgver=4.2.0
+pkgrel=0
pkgdesc="Module for determining appropriate platform-specific dirs"
url="https://github.com/platformdirs/platformdirs"
arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-pytest-mock"
-source="https://files.pythonhosted.org/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz
- fix-version.patch"
+makedepends="py3-gpep517 py3-hatchling py3-hatch-vcs"
+checkdepends="py3-appdirs py3-pytest py3-pytest-mock"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz"
builddir="$srcdir/platformdirs-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH=build/lib pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-06c570f1c206f557fe989e79a1a98da90c05f15a66a56ebbe260884b2250c2cd1a6345d664af63a886268b5a2bb366186927561721fd6a4b52b11eb2868677b1 platformdirs-2.3.0.tar.gz
-dff46866fafb3b8739a84cd95dcb96cd633c82fcd55a4ce4df6f18424e7ff29a2a4c7d47e72c3bc9d93912dc4f36bfe07a1f2a0f397e375ffb7ae6159b357d47 fix-version.patch
+615742163cc4eb0ee97c4dba069d59a08e0056e05a3fbeab32dcab854ed56976e8707dd70afd65dbd0732bf1ad1a42c565fb3d980b7b668aa2cdecc5cc1de4f0 platformdirs-4.2.0.tar.gz
"