aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-platformdirs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-platformdirs/APKBUILD')
-rw-r--r--community/py3-platformdirs/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/community/py3-platformdirs/APKBUILD b/community/py3-platformdirs/APKBUILD
index bc50adc7bac..b244f0784b4 100644
--- a/community/py3-platformdirs/APKBUILD
+++ b/community/py3-platformdirs/APKBUILD
@@ -8,13 +8,15 @@ url="https://github.com/platformdirs/platformdirs"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-build py3-hatchling py3-hatch-vcs py3-installer"
+makedepends="py3-gpep517 py3-hatchling py3-hatch-vcs"
checkdepends="py3-appdirs py3-pytest py3-pytest-mock"
source="https://files.pythonhosted.org/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz"
builddir="$srcdir/platformdirs-$pkgver"
build() {
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 1
}
check() {