aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-plyer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-plyer/APKBUILD')
-rw-r--r--community/py3-plyer/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/py3-plyer/APKBUILD b/community/py3-plyer/APKBUILD
index e7d4647859e..5b1d4acbb98 100644
--- a/community/py3-plyer/APKBUILD
+++ b/community/py3-plyer/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Newbyte <newbyte@disroot.org>
# Maintainer: Newbyte <newbyte@disroot.org>
pkgname=py3-plyer
-pkgver=2.0.0
-pkgrel=0
+pkgver=2.1.0
+pkgrel=2
pkgdesc="Platform-independent wrapper for platform-dependent APIs"
url="https://plyer.readthedocs.io/en/latest"
arch="noarch"
@@ -10,6 +10,7 @@ license="MIT"
depends="python3"
options="!check" # no tests?
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/plyer/plyer-$pkgver.tar.gz"
builddir="$srcdir/plyer-$pkgver"
@@ -18,9 +19,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-8088eeb41aac753435ff5be9835be74d57a55cf557ad76cbad8026352647e554571fae6172754e39882ea7ef07cc1e97fac16556a4426456de99daebe5cd01cf plyer-2.0.0.tar.gz
+000ec0331cbb605ada36a5f0276482a62d827a41570e71e977b4dabd1b495e71f849dbdc4f025a2b71c3ccee62e456f9d9c8b880c4bcde31f643c29c03e6a4ce plyer-2.1.0.tar.gz
"