aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pocketsphinx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pocketsphinx/APKBUILD')
-rw-r--r--community/py3-pocketsphinx/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-pocketsphinx/APKBUILD b/community/py3-pocketsphinx/APKBUILD
index d73251cc9dc..47067eeb96f 100644
--- a/community/py3-pocketsphinx/APKBUILD
+++ b/community/py3-pocketsphinx/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-pocketsphinx
pkgver=0.1.15
-pkgrel=1
+pkgrel=5
pkgdesc="Python interface to CMU Sphinxbase and Pocketsphinx libraries"
url="https://github.com/bambocher/pocketsphinx-python"
arch="all"
@@ -10,6 +10,7 @@ license="BSD-2-Clause"
depends="python3"
makedepends="py3-setuptools swig python3-dev pulseaudio-dev alsa-lib-dev"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/p/pocketsphinx/pocketsphinx-$pkgver.tar.gz"
# PyPi release package doesn't include the tests even though they exist
# https://github.com/bambocher/pocketsphinx-python/issues/55
@@ -21,7 +22,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="5693d76b46fee482439d937425ef78746265db8936747aac6757520adc3b6866dda79972315b7273783d2d3a42194d0b9a78dadf1fab746f6d7f257f3dd3a05a pocketsphinx-0.1.15.tar.gz"