aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-podcastparser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-podcastparser/APKBUILD')
-rw-r--r--community/py3-podcastparser/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-podcastparser/APKBUILD b/community/py3-podcastparser/APKBUILD
new file mode 100644
index 00000000000..24c49dd4a0d
--- /dev/null
+++ b/community/py3-podcastparser/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
+# Contributor: Johannes Marbach <n0-0ne+gitlab@mailbox.org>
+pkgname=py3-podcastparser
+pkgver=0.6.10
+pkgrel=1
+pkgdesc="Simplified, fast RSS parsing library in Python"
+url="https://github.com/gpodder/podcastparser"
+arch="noarch"
+license="ISC"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gpodder/podcastparser/archive/$pkgver.tar.gz"
+builddir="$srcdir/podcastparser-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ make test PYTHON=python3
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+26c2146b5fac35f9c042aa0e1b107eba633fe0eab94e78d738f98e0ad5dadbf8eb0dc777a36839693f2abb0bfc21953d4e1bfecb6ec150f6f9bbd49dd2cf996d py3-podcastparser-0.6.10.tar.gz
+"