aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-polib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-polib/APKBUILD')
-rw-r--r--community/py3-polib/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/py3-polib/APKBUILD b/community/py3-polib/APKBUILD
index 671c06c1a40..214b8f6b99f 100644
--- a/community/py3-polib/APKBUILD
+++ b/community/py3-polib/APKBUILD
@@ -2,20 +2,23 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-polib
_pkgname=polib
-pkgver=1.1.0
-pkgrel=4
-pkgdesc="A library to manipulate gettext files"
-url="http://polib.readthedocs.org/en/latest/index.html"
+pkgver=1.2.0
+pkgrel=2
+pkgdesc="library to manipulate gettext files"
+url="https://polib.readthedocs.org/en/latest/index.html"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces=py-polib # Backwards compatibility
provides=py-polib=$pkgver-r$pkgrel # Backwards compatibility
+options="!check" # tests broken
+
build() {
python3 setup.py build
}
@@ -25,7 +28,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="74681585b4d7252e107acd7d73f49f7e91c90adcd180722d39d35c40ec158434798af0124a16788cf564c73b84f52a040aefeb58355a1a3cd85848c3f6a5e67f polib-1.1.0.tar.gz"
+sha512sums="
+b325730cd4df6c881ffcab72da1796eb2949243f6060c650209e1c6584e5344ecaede870f22ece00f5c74bcd289fa5d2aa5223b88cb78de0dff5f9e41759096e polib-1.2.0.tar.gz
+"