aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-port-for/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-port-for/APKBUILD')
-rw-r--r--community/py3-port-for/APKBUILD30
1 files changed, 22 insertions, 8 deletions
diff --git a/community/py3-port-for/APKBUILD b/community/py3-port-for/APKBUILD
index 6b74d208ed2..3141f95a024 100644
--- a/community/py3-port-for/APKBUILD
+++ b/community/py3-port-for/APKBUILD
@@ -2,24 +2,38 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-port-for
_pkgname=port-for
-pkgver=0.4
-pkgrel=2
+pkgver=0.7.2
+pkgrel=1
pkgdesc="Utility and library that helps with local TCP ports management"
-options="!check" # No testsuite in pypi tarball
url="https://github.com/kmike/port-for"
arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+
+ # Low ports are available on the CI
+ .testenv/bin/python3 -m pytest \
+ -k 'test_binding_high or not test_binding'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/port_for*.whl
}
-sha512sums="476b7273d868c84d7a0a6f49f93b4d0c8d4cd449adc800c7f587e5201d52234c89d6f768f9c20dbf61a55fc52d884146ab3b02db313ab2b4c6afd2f046b03c98 port-for-0.4.tar.gz"
+sha512sums="
+093d35af3954f5d21753f1ecfcdb616829bfd6079e5f8b2208930881d12c93cbc9a065ca53289d9836ba1c266637661f518fb4cc61bc7a33aa5e469589b65e4c port-for-0.7.2.tar.gz
+"