aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-portalocker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-portalocker/APKBUILD')
-rw-r--r--community/py3-portalocker/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/py3-portalocker/APKBUILD b/community/py3-portalocker/APKBUILD
index 337f6b4d0a0..8cc801a9370 100644
--- a/community/py3-portalocker/APKBUILD
+++ b/community/py3-portalocker/APKBUILD
@@ -1,7 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
+# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-portalocker
-pkgver=2.3.0
+pkgver=2.8.2
pkgrel=0
pkgdesc="An extended version of portalocker to lock files in Python using the with statement"
url="http://portalocker.readthedocs.io/en/latest/"
@@ -16,6 +17,8 @@ depends="
"
makedepends="
py3-setuptools
+ py3-gpep517
+ py3-wheel
py3-sphinx
"
checkdepends="
@@ -23,23 +26,27 @@ checkdepends="
py3-pytest
py3-pytest-cov
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/p/portalocker/portalocker-$pkgver.tar.gz"
# Tests requires deprecated Python package pytest-flakes and pytest-pep8
options="!check"
builddir="$srcdir/portalocker-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ pytest -v
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-3d2431509db8367f963c0e810002efa7ee15f0b0ac8f5ca52cd5ebabfcd94ee9f62771dc0574e14c3195b9868e119e3bd1eef01459d69b6a0d1c6f23915f9b57 portalocker-2.3.0.tar.gz
+9ebd6fdbc597615c5f76bf5741556d84bc95c925e931ee708b4fccbf0908e4dc4e758be659928340675675f5ca09764f5d2621fdef9195e21c1359f7764ae1dc portalocker-2.8.2.tar.gz
"