aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-portend/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-portend/APKBUILD')
-rw-r--r--community/py3-portend/APKBUILD34
1 files changed, 22 insertions, 12 deletions
diff --git a/community/py3-portend/APKBUILD b/community/py3-portend/APKBUILD
index 208d0fe9b29..82cf3f51ddd 100644
--- a/community/py3-portend/APKBUILD
+++ b/community/py3-portend/APKBUILD
@@ -1,35 +1,45 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-portend
-pkgver=2.7.1
-pkgrel=0
+pkgver=3.2.0
+pkgrel=1
pkgdesc="TCP port monitoring and discovery"
url="https://github.com/jaraco/portend"
arch="noarch"
license="MIT"
-depends="
- py3-tempora
- python3
- "
+depends="py3-tempora"
+# py3-setuptools_scm is required to set version of python module
makedepends="
py3-setuptools
py3-setuptools_scm
- py3-toml
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="
+ py3-freezegun
+ py3-pytest
"
-checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/p/portend/portend-$pkgver.tar.gz"
builddir="$srcdir/portend-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="079bfc286491753e980b5000ee716031225439523a8d9a79c2571359adee74ee024dd680c41adb966487dc39eea3d0dbeb928c5c72fa21ab897283310ef21906 portend-2.7.1.tar.gz"
+sha512sums="
+56790cdb6d1619e8873acc2498f9bee758a64ad8f8e47f31e48ae1ac7b6f038fc81af5d52cbc4bc4797dd6dc25d453d391d73d454c98559b1d6a8e9061837d7f portend-3.2.0.tar.gz
+"