aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-prettytable/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-prettytable/APKBUILD')
-rw-r--r--community/py3-prettytable/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/py3-prettytable/APKBUILD b/community/py3-prettytable/APKBUILD
index 4b5ccdec798..a61102dbc48 100644
--- a/community/py3-prettytable/APKBUILD
+++ b/community/py3-prettytable/APKBUILD
@@ -3,13 +3,15 @@
pkgname=py3-prettytable
_pkgname=prettytable
pkgver=0.7.2
-pkgrel=6
+pkgrel=12
pkgdesc="Python library for easily displaying tabular data"
-url="https://code.google.com/p/prettytable"
+url="https://github.com/jazzband/prettytable"
arch="noarch"
license="BSD-3-Clause"
-depends="python3"
+depends="python3 !py3-prettytable3"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/P/PrettyTable/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -21,12 +23,14 @@ build() {
}
check() {
- python3 setup.py test
+ pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
chmod a+rX "$pkgdir"/usr/lib/python3*/site-packages/*.egg-info/*
}
-sha512sums="84611b9ad11bd428cdb00795e0a9baff44d027331b73ed1742596acda8acc8aca3df4276fa2f2ca2289f10b2989b3c86556de70bca6a9773b15cd80c54c33117 prettytable-0.7.2.tar.gz"
+sha512sums="
+84611b9ad11bd428cdb00795e0a9baff44d027331b73ed1742596acda8acc8aca3df4276fa2f2ca2289f10b2989b3c86556de70bca6a9773b15cd80c54c33117 prettytable-0.7.2.tar.gz
+"