aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-progress/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-progress/APKBUILD')
-rw-r--r--community/py3-progress/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-progress/APKBUILD b/community/py3-progress/APKBUILD
new file mode 100644
index 00000000000..c62f4601ce1
--- /dev/null
+++ b/community/py3-progress/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-progress
+pkgver=1.6
+pkgrel=4
+pkgdesc="Easy to use progress bars for Python3"
+url="https://github.com/verigak/progress"
+arch="noarch"
+license="ISC"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/verigak/progress/archive/$pkgver.tar.gz"
+builddir="$srcdir/progress-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 test_progress.py
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+e6afd7ecda8cfbda578b53a8f9ced9a017bfa42d3ffe0fbefbcbb3715024983543c919e5d8276b5cd79bebe9e7d9c2b7234e6d8cd20b3142058c28ee4418ff3a py3-progress-1.6.tar.gz
+"