aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-prompt_toolkit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-prompt_toolkit/APKBUILD')
-rw-r--r--community/py3-prompt_toolkit/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/py3-prompt_toolkit/APKBUILD b/community/py3-prompt_toolkit/APKBUILD
index 27e017115a4..7b1033984f8 100644
--- a/community/py3-prompt_toolkit/APKBUILD
+++ b/community/py3-prompt_toolkit/APKBUILD
@@ -1,31 +1,43 @@
# Contributor: Thomas Boerger <thomas@webhippie.de>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=py3-prompt_toolkit
-_pkgname=prompt_toolkit
-pkgver=3.0.5
-pkgrel=0
+pkgver=3.0.43
+pkgrel=1
pkgdesc="Library for building powerful interactive command lines in Python"
-url="https://pypi.python.org/pypi/prompt_toolkit"
+url="https://github.com/prompt-toolkit/python-prompt-toolkit"
arch="noarch"
license="BSD-3-Clause"
-depends="py3-six py3-wcwidth"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/p/${_pkgname}/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+depends="python3 py3-wcwidth"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/prompt-toolkit/python-prompt-toolkit/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/python-prompt-toolkit-$pkgver"
replaces=py-prompt_toolkit # Backwards compatibility
provides=py-prompt_toolkit=$pkgver-r$pkgrel # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="fe6cfc7223529b77bdfa34dbebc8f5690ac6a1d0082cbf3f03f49598408bcff082697df1bd7ee427c796fe0c8d73126a965269e77ed0e6f1519b338b464995a7 prompt_toolkit-3.0.5.tar.gz"
+sha512sums="
+68014ba52b90d0743f58ffee265d3860855d1a0939c75384fcbdff265e32c7faa058e9048e056b7c73e6d9541668ea845c7fd08c0a5303b8f650d73f95b8b743 py3-prompt_toolkit-3.0.43.tar.gz
+"