aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-protobuf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-protobuf/APKBUILD')
-rw-r--r--community/py3-protobuf/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/community/py3-protobuf/APKBUILD b/community/py3-protobuf/APKBUILD
index c940a92b1dc..c6405e0d4ad 100644
--- a/community/py3-protobuf/APKBUILD
+++ b/community/py3-protobuf/APKBUILD
@@ -1,19 +1,22 @@
# Contributor: Corentin Henry <corentinhenry@gmail.com>
-# Maintainer:
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-protobuf
-pkgver=3.15.7
-pkgrel=0
+pkgver=4.24.4
+_protobuf=${pkgver#*.}
+pkgrel=1
pkgdesc="Google's data interchange format"
-options="!check" # Fails due to new 'packaging' module
-url="https://github.com/google/protobuf"
+url="https://github.com/protocolbuffers/protobuf"
arch="noarch"
license="BSD-3-Clause"
-depends="py3-six>=1.9"
-makedepends="protobuf py3-setuptools py3-wheel"
+depends="tzdata"
+makedepends="protobuf-dev py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-numpy"
# NOTE: Always use releases of protobuf, not pypi or auto-generated GitHub
# tarballs as they do not contain the necessary components to run tests.
-source="https://github.com/protocolbuffers/protobuf/releases/download/v$pkgver/protobuf-python-$pkgver.tar.gz"
-builddir="$srcdir"/protobuf-$pkgver/python
+subpackages="$pkgname-pyc"
+source="https://github.com/protocolbuffers/protobuf/releases/download/v$_protobuf/protobuf-$_protobuf.tar.gz"
+builddir="$srcdir"/protobuf-$_protobuf/python
+options="!check" # seem to not generate some test protos
replaces="py-protobuf" # Backwards compatibility
provides="py-protobuf=$pkgver-r$pkgrel" # Backwards compatibility
@@ -23,14 +26,16 @@ build() {
}
check() {
- python3 setup.py test
+ pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
# correct permissions
- chmod +r "$subpkgdir"/usr/lib/*/site-packages/*/*
+ chmod +r "$pkgdir"/usr/lib/*/site-packages/*/*
}
-sha512sums="62995a275745ed5e8581274c52c47fe9d42ede639ec50e4cdb7746d73a0408241810213c7136a999e37a188a9e7db950f4b8d072e95f32bf53aac96006aa4778 protobuf-python-3.15.7.tar.gz"
+sha512sums="
+52b6ab5587d03cbd1f35cf3cdc388e1710fa50f3031559ac53cf754965407ded7602cdead56080444ab695588112cc3391a1d7fdd5e565d90d0af7ad08706315 protobuf-24.4.tar.gz
+"