aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-purl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-purl/APKBUILD')
-rw-r--r--community/py3-purl/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/py3-purl/APKBUILD b/community/py3-purl/APKBUILD
index 5d5ec9ffd46..a0bf3662e0d 100644
--- a/community/py3-purl/APKBUILD
+++ b/community/py3-purl/APKBUILD
@@ -2,17 +2,17 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-purl
_pkgname=purl
-pkgver=1.5
+pkgver=1.6
pkgrel=4
-pkgdesc="An immutable Python3 URL class for easy URL-building and manipulation"
+pkgdesc="immutable Python3 URL class for easy URL-building and manipulation"
url="https://github.com/codeinthehole/purl"
arch="noarch"
license="MIT"
-depends="py3-six"
# Tests are not included in the tarball
options="!check"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -24,7 +24,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="e7ef3dbe51117c2807a5cd472967d90c9f16fc1090f2edcaf3c4fe0bbc95b8ef8d612d5ca98401caf5a94c5b0335949ac0ac490bc694e571ff516b7bf53fae32 purl-1.5.tar.gz"
+sha512sums="
+1c0046a50d3ed3653bc3f5d5062863d5dfa23a3259491163b511209ee185c9be43d6fefb0cacf46cab3e894cfede36590830de8fc668088dc7d5df1c2215f857 purl-1.6.tar.gz
+"