aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-purl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-purl/APKBUILD')
-rw-r--r--community/py3-purl/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-purl/APKBUILD b/community/py3-purl/APKBUILD
new file mode 100644
index 00000000000..a0bf3662e0d
--- /dev/null
+++ b/community/py3-purl/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-purl
+_pkgname=purl
+pkgver=1.6
+pkgrel=4
+pkgdesc="immutable Python3 URL class for easy URL-building and manipulation"
+url="https://github.com/codeinthehole/purl"
+arch="noarch"
+license="MIT"
+# Tests are not included in the tarball
+options="!check"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-purl" # Backwards compatibility
+provides="py-purl=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+1c0046a50d3ed3653bc3f5d5062863d5dfa23a3259491163b511209ee185c9be43d6fefb0cacf46cab3e894cfede36590830de8fc668088dc7d5df1c2215f857 purl-1.6.tar.gz
+"