aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-py-cpuinfo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-py-cpuinfo/APKBUILD')
-rw-r--r--community/py3-py-cpuinfo/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/community/py3-py-cpuinfo/APKBUILD b/community/py3-py-cpuinfo/APKBUILD
index f57bf0ed0d2..90644c69506 100644
--- a/community/py3-py-cpuinfo/APKBUILD
+++ b/community/py3-py-cpuinfo/APKBUILD
@@ -2,33 +2,42 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-py-cpuinfo
_pkgname=py-cpuinfo
-pkgver=5.0.0
-pkgrel=5
+pkgver=9.0.0
+pkgrel=4
pkgdesc="Pure-Python module for getting CPU info"
url="https://github.com/workhorsy/py-cpuinfo"
-# does not actually work on mips
-arch="noarch !mips !mips64"
+arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- add-s390x.patch"
+ py-cpuinfo-loongarch64.patch
+ disable-test-from-proc-cpuinfo.patch
+ "
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-cpuinfo" # Backwards compatibility
provides="py-cpuinfo=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m unittest -v
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/py_cpu*.whl
}
-sha512sums="d3a22ffdc4d1668a58330016e3297e57c07f6380e544497b1ad9dfcf0410b000f69418bf1cb9a434a2ffdbc8f17be89a25d33c65817913a823c6e181df6b760e py-cpuinfo-5.0.0.tar.gz
-98b361419e54b0386dc026575d5be18494c2c22f0a102045bd84af18e0691427327421721e0d747b823cb583f02a74606195bf2e4ab990ffaedd39fd0ca0118c add-s390x.patch"
+sha512sums="
+c7711137d60ad52bcbef8738a70fb48ceaa69e1e1632d135d0ee95c282b02df6170c3dd88a1e14b3e9a386d3286a15ca9722fcfb596107da022161a7cf84509a py-cpuinfo-9.0.0.tar.gz
+87e8d952c4aeee459f28abc75ce4a7fb6557053160b2d29afe28cfc05d922f4f550cc93757c4fbfd47b98e3f0447383a7a3609d982713970c482e2d4e490372e py-cpuinfo-loongarch64.patch
+37b1835d2817d71abd769989feca95fcc2652e2b257165951f942ca6fa49ceee6b24c82e372db4b9087b665fd22d52ab83f5dec1b303386e8cd0d972d0f02481 disable-test-from-proc-cpuinfo.patch
+"