aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyaes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyaes/APKBUILD')
-rw-r--r--community/py3-pyaes/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-pyaes/APKBUILD b/community/py3-pyaes/APKBUILD
index 89adb114d35..1149153fbd7 100644
--- a/community/py3-pyaes/APKBUILD
+++ b/community/py3-pyaes/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-pyaes
pkgver=1.6.1
-pkgrel=2
+pkgrel=6
pkgdesc="Pure-Python Implementation of the AES block-cipher and common modes of operation"
url="https://github.com/ricmoo/pyaes"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pyaes/pyaes-$pkgver.tar.gz"
builddir="$srcdir/pyaes-$pkgver"
@@ -21,7 +22,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="00ce3babf72ea18b0de369860cd884058c7c6f3bd8b961c3ff591ef7d3dc0a69fabad5311f61c9f91d2f1a480c8512e34eeced5ec7145ed9f963bf91c5f8838a pyaes-1.6.1.tar.gz"