aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyaudio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyaudio/APKBUILD')
-rw-r--r--community/py3-pyaudio/APKBUILD29
1 files changed, 24 insertions, 5 deletions
diff --git a/community/py3-pyaudio/APKBUILD b/community/py3-pyaudio/APKBUILD
index e55a2c22048..dbffabf9a16 100644
--- a/community/py3-pyaudio/APKBUILD
+++ b/community/py3-pyaudio/APKBUILD
@@ -1,24 +1,43 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-pyaudio
-pkgver=0.2.11
+pkgver=0.2.14
pkgrel=1
pkgdesc="Bindings for PortAudio v19, the cross-platform audio input/output stream library"
url="https://people.csail.mit.edu/hubert/pyaudio/"
arch="all"
license="MIT"
depends="python3"
-makedepends="py3-setuptools python3-dev portaudio-dev"
+makedepends="
+ portaudio-dev
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/P/PyAudio/PyAudio-$pkgver.tar.gz"
options="!check" # No tests
builddir="$srcdir/PyAudio-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="64db5542ee60837c9b07677e146fc7b060ff47c8b1c04cbb575bce79dd3ed4776c201e169ff2860f27dbe9e00a77046ba0cb925b55f7c546f8de46c6df68954e PyAudio-0.2.11.tar.gz"
+sha512sums="
+2133db0968edcb0d82c6c1922f842d045a32c77998cfae8b38a041c67650cfacf9f6354c8a252db1b5148f73d229940b4c27064b400d2de7ab7e9370f73b8b95 PyAudio-0.2.14.tar.gz
+"