aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pychromecast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pychromecast/APKBUILD')
-rw-r--r--community/py3-pychromecast/APKBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/community/py3-pychromecast/APKBUILD b/community/py3-pychromecast/APKBUILD
index 702805902b0..b13b4cc41ce 100644
--- a/community/py3-pychromecast/APKBUILD
+++ b/community/py3-pychromecast/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer:
+# Maintainer: Magnus Sandin <magnus.sandin@gmail.com>
pkgname=py3-pychromecast
-pkgver=9.2.1
-pkgrel=1
+pkgver=14.0.1
+pkgrel=0
pkgdesc="Python module to talk to Google Chromecast"
-url="https://github.com/balloob/pychromecast"
+url="https://github.com/home-assistant-libs/pychromecast"
arch="noarch"
license="MIT"
depends="
@@ -13,22 +13,31 @@ depends="
py3-zeroconf
python3
"
-makedepends="py3-setuptools"
+makedepends="
+ py3-build
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/P/PyChromecast/PyChromecast-$pkgver.tar.gz"
options="!check" # No tests
builddir="$srcdir/PyChromecast-$pkgver"
-provides="py3-chromecast" # Backwards compatibility
-replaces="py3-chromecast=$pkgver-r$pkgrel" # Backwards compatibility
+provides="py3-chromecast=$pkgver-r$pkgrel" # Backwards compatibility
+replaces="py3-chromecast" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-5f5829f06da02549d94effefc5251a06043e31fef186cc714fbbc29d6505af63448b18ac36cd7fbd27e8575c4821dbb3c4c55dc06c7dcff8123375d52417dabe PyChromecast-9.2.1.tar.gz
+72119e27be49128d57a9354aaebd2a5711f3da0ad2e7ca07863107382061d9398c95c901ac33ea2a1c45687b2cbef32dfdba228be99e1acdef79ce133510fb4e PyChromecast-14.0.1.tar.gz
"