aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyclip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyclip/APKBUILD')
-rw-r--r--community/py3-pyclip/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/py3-pyclip/APKBUILD b/community/py3-pyclip/APKBUILD
new file mode 100644
index 00000000000..f279f776d51
--- /dev/null
+++ b/community/py3-pyclip/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-pyclip
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Cross-platform clipboard utilities supporting both binary and text data"
+url="https://github.com/spyoungtech/pyclip"
+arch="noarch"
+license="Apache-2.0"
+depends="
+ cmd:xclip
+ python3
+ "
+makedepends="py3-setuptools xclip"
+checkdepends="py3-pytest"
+source="https://github.com/spyoungtech/pyclip/archive/v$pkgver/pyclip-v$pkgver.tar.gz"
+options="!check" # Requires working tty
+builddir="$srcdir/pyclip-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+64849befe020b0ac38aa8ed93ceb7fb275112aa49ae527fc54916ea591e09ce5a1a669d8f68083b098112a90fd36f71d2abeef6c3a8908e6cde20f04b0273877 pyclip-v0.7.0.tar.gz
+"