aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyfakefs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyfakefs/APKBUILD')
-rw-r--r--community/py3-pyfakefs/APKBUILD46
1 files changed, 34 insertions, 12 deletions
diff --git a/community/py3-pyfakefs/APKBUILD b/community/py3-pyfakefs/APKBUILD
index 1cf349f2784..969ad3dea5e 100644
--- a/community/py3-pyfakefs/APKBUILD
+++ b/community/py3-pyfakefs/APKBUILD
@@ -1,28 +1,50 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-pyfakefs
_pkgname=${pkgname#py3-}
-pkgver=4.4.0
-pkgrel=0
+pkgver=5.3.5
+pkgrel=1
pkgdesc="fake file system that mocks the Python file system modules"
-url="https://github.com/jmcgeheeiv/pyfakefs/"
+url="https://github.com/pytest-dev/pyfakefs/"
arch="noarch"
license="Apache-2.0"
-depends=""
-makedepends="py3-setuptools"
-checkdepends=""
+depends="python3"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+case "$CARCH" in
+# fails on builder currently
+aarch64|armhf|armv7|riscv64) _test_filter='not test_chown_follow_symlink and not test_chown_no_follow_symlink' ;;
+esac
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+
+ # pytest_fixture_test.py: needs currently unpackaged 'undefined' module
+ .testenv/bin/python3 -m pytest \
+ --ignore pyfakefs/pytest_tests/pytest_fixture_test.py \
+ -k "$_test_filter"
}
-check() {
- python3 setup.py test
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -r "$pkgdir"/usr/lib/python*/site-packages/pyfakefs/*tests
}
-sha512sums="1d00e2ff7b21f263373aa96cbcf2af4d3a4d577af792dd00d2a3ef6e854b80de870d009183e6b96a4b731a4e4e297c8be75ff1116dc9dde09a3bef4383c8dd06 pyfakefs-4.4.0.tar.gz"
+sha512sums="
+c477f3f6e2754100f320a9a966cdb69ec0845c68ce9428bbb72bf723d646ef007c94ff17336170a7861e45f83a5e8d7fbd72460345b7565570ab5494652d75c7 pyfakefs-5.3.5.tar.gz
+"