aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pygit2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pygit2/APKBUILD')
-rw-r--r--community/py3-pygit2/APKBUILD39
1 files changed, 28 insertions, 11 deletions
diff --git a/community/py3-pygit2/APKBUILD b/community/py3-pygit2/APKBUILD
index 8c416c80423..d01288315f2 100644
--- a/community/py3-pygit2/APKBUILD
+++ b/community/py3-pygit2/APKBUILD
@@ -1,19 +1,30 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Pierre-Gildas MILLON <pgmillon@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-pygit2
_pkgname=pygit2
-pkgver=1.7.0
+pkgver=1.14.1
pkgrel=0
pkgdesc="Python bindings for libgit2"
url="https://github.com/libgit2/pygit2"
arch="all"
-license="GPL-2.0 WITH GCC-exception-2.0"
+license="GPL-2.0-only WITH GCC-exception-2.0"
depends="py3-cffi py3-cached-property"
-makedepends="python3-dev py3-setuptools libgit2-dev"
-checkdepends="py3-pytest py3-hypothesis"
-source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
+makedepends="
+ libgit2-dev
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="
+ py3-hypothesis
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libgit2/pygit2/archive/refs/tags/v$pkgver.tar.gz
s390x-patch-context-mark-xfail.patch
+ test-skip-ls-remote-github.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -24,18 +35,24 @@ provides="py-pygit=$pkgver-r$pkgrel" # Backward compat
[ "$CARCH" = "s390x" ] && options="!check"
build() {
- python3 setup.py build_ext --inplace
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest-3
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-3a8654036d0ab875898ce60e81bcab48bdb6d6bd63c29dc98272c71b5c82391e3186da61083fba09faf722e176fed5c592a36edb53ae0b957726e74646d25616 pygit2-1.7.0.tar.gz
-c0e22ae9a50cb727bae87fd2b03c5b71b7aee77b88764133b9d60d78a9903895d80db10c037859cbc9bfc06d251c2ed169b63c06798e70169de2b39b12fa0fc5 s390x-patch-context-mark-xfail.patch
+7d48c60df5af47fe5f90661cec6d53e3b4adb5e14b4d605fc4634f38222b4053d59156a55814849b1cd0619b169c6d35bc387912695e54c18fdd2b57de7b561d py3-pygit2-1.14.1.tar.gz
+e7f3a43f2de1503d75c5583c4d9a30027dd3d619ba02e7e62bed3b912e8c91e4bc58ad395b110eb506b365bebf99d4245837c65c9988f15e4dc41f0f87fe7c13 s390x-patch-context-mark-xfail.patch
+c0114b96d0064f272f166a6af915a1abcadc1ec8aac0c84007e4f24d669784d42c24f50ad71118453f0fb25b6f38f991a9d6f968d1a21f017c4662c9ba9c5c41 test-skip-ls-remote-github.patch
"