aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pykka/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pykka/APKBUILD')
-rw-r--r--community/py3-pykka/APKBUILD33
1 files changed, 23 insertions, 10 deletions
diff --git a/community/py3-pykka/APKBUILD b/community/py3-pykka/APKBUILD
index 0d4978fad0a..e6c7f4d6d54 100644
--- a/community/py3-pykka/APKBUILD
+++ b/community/py3-pykka/APKBUILD
@@ -1,34 +1,47 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-pykka
-pkgver=3.0.1
-pkgrel=0
+pkgver=4.0.2
+pkgrel=1
pkgdesc="Concurrency abstractions for Python3 using the actor model"
url="https://pykka.readthedocs.org/"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="https://pypi.python.org/packages/source/p/pykka/pykka-$pkgver.tar.gz"
-options="!check" # Pypi release contains no tests and Github source has no setup.py
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-poetry-core
+ "
+checkdepends="
+ py3-mock
+ py3-pytest
+ py3-pytest-mock
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/jodal/pykka/archive/v$pkgver/pykka-$pkgver.tar.gz"
builddir="$srcdir/pykka-$pkgver"
replaces="py-pykka" # Backwards compatibility
provides="py-pykka=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-384866f8257040f67cc65de23773bfdbedecd88961570fb579c96d8f8348546f3b7eb1e64420f68ad4623448a45556a9c1dc5f255405b8da4ed61601257540fb pykka-3.0.1.tar.gz
+43d31258f73a6d43c467d108066dd3e852db9e21a04fda030137dbd65052a874e346ed78b79a4929b25d2744a286c95d5d425ae150428ea1594a24f2a6c6a164 pykka-4.0.2.tar.gz
"