aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pykka/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pykka/APKBUILD')
-rw-r--r--community/py3-pykka/APKBUILD35
1 files changed, 26 insertions, 9 deletions
diff --git a/community/py3-pykka/APKBUILD b/community/py3-pykka/APKBUILD
index 5d40febe3f0..e6c7f4d6d54 100644
--- a/community/py3-pykka/APKBUILD
+++ b/community/py3-pykka/APKBUILD
@@ -1,30 +1,47 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-pykka
-pkgver=2.0.3
-pkgrel=0
+pkgver=4.0.2
+pkgrel=1
pkgdesc="Concurrency abstractions for Python3 using the actor model"
url="https://pykka.readthedocs.org/"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/P/Pykka/Pykka-$pkgver.tar.gz"
-builddir="$srcdir"/Pykka-$pkgver
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-poetry-core
+ "
+checkdepends="
+ py3-mock
+ py3-pytest
+ py3-pytest-mock
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/jodal/pykka/archive/v$pkgver/pykka-$pkgver.tar.gz"
+builddir="$srcdir/pykka-$pkgver"
replaces="py-pykka" # Backwards compatibility
provides="py-pykka=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="0f4d6d9e0c92a7e7cafb340f343afa1e78bcefdd0454341d3f457fa202acdd3de979881689cb3cd5f2cbd3a08f80177f6470db4fb895b20d9c1b4d0b9ef627ee Pykka-2.0.3.tar.gz"
+sha512sums="
+43d31258f73a6d43c467d108066dd3e852db9e21a04fda030137dbd65052a874e346ed78b79a4929b25d2744a286c95d5d425ae150428ea1594a24f2a6c6a164 pykka-4.0.2.tar.gz
+"