aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pylast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pylast/APKBUILD')
-rw-r--r--community/py3-pylast/APKBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/community/py3-pylast/APKBUILD b/community/py3-pylast/APKBUILD
index febee4e7170..7fe169a1ba0 100644
--- a/community/py3-pylast/APKBUILD
+++ b/community/py3-pylast/APKBUILD
@@ -1,33 +1,32 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pylast
-pkgver=4.5.0
-pkgrel=0
-pkgdesc="A Python interface to the last.fm API"
+pkgver=5.2.0
+pkgrel=1
+pkgdesc="Python interface to the last.fm API"
url="https://github.com/pylast/pylast"
-arch="noarch"
+arch="noarch !ppc64le !armhf" # py3-httpx
license="Apache-2.0"
replaces="py-pylast"
# Requires unpackaged flaky
options="!check"
-depends="python3"
-makedepends="py3-setuptools py3-setuptools_scm"
+depends="python3 py3-httpx"
+makedepends="py3-gpep517 py3-hatchling py3-hatch-vcs"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pylast/pylast-$pkgver.tar.gz"
builddir="$srcdir"/pylast-$pkgver
build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pylast*.whl
}
-
sha512sums="
-66b43d6d0acfab21b56a1ad955e4389c81060914d1c1fb15bd96f8eaff2504883bbb2175994c6f7ba2073898782dd83b255fe9c2e7c4ce9ff5a064f541197053 pylast-4.5.0.tar.gz
+1ae76ff4ec6f009388abfcf8525f1c19e47cbabaace1f5e8c518819d0856168d855b789e3c08a9699dd7ab88ebfc7c3ab81c2d74a0fa1fd210450741b99da8c6 pylast-5.2.0.tar.gz
"