aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pylint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pylint/APKBUILD')
-rw-r--r--community/py3-pylint/APKBUILD43
1 files changed, 29 insertions, 14 deletions
diff --git a/community/py3-pylint/APKBUILD b/community/py3-pylint/APKBUILD
index 3ef97cd308d..33131e51adb 100644
--- a/community/py3-pylint/APKBUILD
+++ b/community/py3-pylint/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pylint
-pkgver=2.10.2
+pkgver=3.1.0
pkgrel=1
pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
url="https://github.com/PyCQA/pylint"
@@ -9,36 +9,51 @@ arch="noarch"
license="GPL-2.0-or-later"
depends="
py3-astroid
+ py3-dill
py3-isort
py3-mccabe
py3-platformdirs
- py3-toml
+ py3-tomlkit
+ "
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-wheel
"
-makedepends="py3-setuptools"
checkdepends="
- py3-pytest
+ py3-gitpython
+ py3-py
+ py3-pytest7
+ py3-pytest-benchmark
+ py3-pytest-cov
py3-pytest-runner
+ py3-pytest-timeout
+ py3-pytest-xdist
+ py3-requests
+ py3-typing-extensions
"
-options="!check" # https://github.com/PyCQA/pylint/issues/3895
-source="https://files.pythonhosted.org/packages/source/p/pylint/pylint-$pkgver.tar.gz
- "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PyCQA/pylint/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir"/pylint-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Requires unpackaged 'pytest-benchmark'
- rm -rf tests/benchmark
-# PYTHONPATH="$PWD/build/lib" py.test-3
- python3 setup.py pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest --benchmark-disable --deselect tests/test_functional.py::test_functional tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pylint-*.whl
}
sha512sums="
-70121f19e51a5373634b92b8c5f3240dbc70ba1803bff4ab2d7c4b7b2a47d7c586b1a69df6a8b55607bc7fb201af57d40c668d297508ec21778541d674ab049f pylint-2.10.2.tar.gz
+bb7f09fa8b2c6f218c0e4d74ec2d7bbcb5e9d9fa8c2aeae5a1bf899f25080251609f284959fab14dd93cc5dd911688e25d3d4e1e030a1790578bc78ef1ce2bf7 py3-pylint-3.1.0.tar.gz
"