aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pylint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pylint/APKBUILD')
-rw-r--r--community/py3-pylint/APKBUILD43
1 files changed, 28 insertions, 15 deletions
diff --git a/community/py3-pylint/APKBUILD b/community/py3-pylint/APKBUILD
index 309121eae5e..1773e5f09e0 100644
--- a/community/py3-pylint/APKBUILD
+++ b/community/py3-pylint/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pylint
-pkgver=2.8.2
+pkgver=2.17.7
pkgrel=0
pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
url="https://github.com/PyCQA/pylint"
@@ -9,37 +9,50 @@ arch="noarch"
license="GPL-2.0-or-later"
depends="
py3-astroid
+ py3-dill
py3-isort
py3-mccabe
- py3-toml
+ py3-platformdirs
+ py3-tomlkit
+ "
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-wheel
"
-makedepends="py3-setuptools"
checkdepends="
+ py3-gitpython
+ py3-py
py3-pytest
+ py3-pytest-benchmark
py3-pytest-runner
+ py3-pytest-timeout
+ py3-pytest-xdist
+ py3-requests
+ py3-typing-extensions
"
-options="!check" # https://github.com/PyCQA/pylint/issues/3895
-source="https://files.pythonhosted.org/packages/source/p/pylint/pylint-$pkgver.tar.gz
- no_setuptools_scm.patch
- "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PyCQA/pylint/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir"/pylint-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Requires unpackaged 'pytest-benchmark'
- rm -rf tests/benchmark
-# PYTHONPATH="$PWD/build/lib" py.test-3
- python3 setup.py pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest --benchmark-disable tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pylint-*.whl
}
sha512sums="
-304cb32fc72a6efe89d3d6799b1bf5ffa2a16220b99d8f0aa39753aeea907c88ed81ddebfc4de91be33243dd47dd1bcde4077fb6428f6fa4fe80636c77be907e pylint-2.8.2.tar.gz
-d3ec0c6acf7a3d32f30fe1dce1710e816b97de6e694c52097e4d5b3dc4edbbc04b93be56147dd7e4da6a34c9545328fa8b1b7db023434b74897e79c09b23b464 no_setuptools_scm.patch
+514fe9d244a58e21fade66f0e343f2162a2fc2f99d7197f4d91801250c13fde2ddc365f92a274d89d602689466a12bac3ff9dd364ce15891171ef86d6313aba2 py3-pylint-2.17.7.tar.gz
"