aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pymediainfo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pymediainfo/APKBUILD')
-rw-r--r--community/py3-pymediainfo/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/py3-pymediainfo/APKBUILD b/community/py3-pymediainfo/APKBUILD
index b2ebf11f436..824f61099ce 100644
--- a/community/py3-pymediainfo/APKBUILD
+++ b/community/py3-pymediainfo/APKBUILD
@@ -2,32 +2,36 @@
# Maintainer: Philipp Glaum <p@pglaum.de>
pkgname=py3-pymediainfo
_pkgname=pymediainfo
-pkgver=5.1.0
-pkgrel=0
+pkgver=6.1.0
+pkgrel=1
pkgdesc="Python wrapper for the MediaInfo library"
url="https://pypi.org/project/pymediainfo/"
arch="noarch"
license="MIT"
-depends="python3 libmediainfo"
-checkdepends="py3-pytest py3-pytest-runner"
-makedepends="py3-setuptools py3-setuptools_scm"
+depends="libmediainfo"
+makedepends="py3-gpep517 py3-setuptools py3-setuptools_scm py3-wheel"
+checkdepends="py3-pytest-xdist py3-pytest-runner"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # skip failing tests
- PYTHONPATH="$PWD"/build/lib pytest \
- -k 'not test_thread_safety[sample.mp4] and not test_thread_safety[sample.mkv]'
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-d3c48e37f6d59b0f5bc1d66d4fad9fea26724863dc2ae75a30c80d972f68f3be650298d25105d330c20b83083f94d2ff5e2690c29573897e09afa44931f3228e pymediainfo-5.1.0.tar.gz
+2c32134f42794a7228591d96e2cbe64b30693b671ded4e386b08eb6d571459e4a06d551d3c169dd340f560cf5ec7f86f6cd73fc135e4404614c22ed452273783 pymediainfo-6.1.0.tar.gz
"