aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pynvim/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pynvim/APKBUILD')
-rw-r--r--community/py3-pynvim/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/py3-pynvim/APKBUILD b/community/py3-pynvim/APKBUILD
index 89a1307bf9e..24683b5f0e4 100644
--- a/community/py3-pynvim/APKBUILD
+++ b/community/py3-pynvim/APKBUILD
@@ -2,28 +2,36 @@
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=py3-pynvim
_pyname=pynvim
-pkgver=0.4.3
-pkgrel=2
+pkgver=0.5.0
+pkgrel=0
pkgdesc="python client and plugin host for Nvim"
-options="!check" # Tests fail on the builders
url="https://github.com/neovim/pynvim"
-arch="noarch !riscv64" # rv64 no luajit
+arch="noarch"
license="Apache-2.0"
-depends="neovim python3 py3-msgpack py3-greenlet"
-makedepends="py3-setuptools"
+depends="neovim py3-msgpack py3-greenlet"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest py3-pytest-runner"
+subpackages="$pkgname-pyc"
source="$_pyname-$pkgver.tar.gz::https://github.com/neovim/$_pyname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --system-site-packages testenv
+ testenv/bin/python3 -m installer dist/*.whl
+ testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ dist/*.whl
}
-sha512sums="5d8fc7623a5bc2e069991b901dbd4dcc6005ddab31e2f0a70ee50c2d6febf3b5c29a61fc4dce454aa494779d7a869a1e92a2a97cb66212ed858c3d3fd77c0f55 pynvim-0.4.3.tar.gz"
+
+sha512sums="
+91ffe3f42cc23ba372223b8c9f6930b0cff9d30b6764052a77a5c34e39a3312a1834b9a753152e96d04d5b4b61ce647bd7470095fac3122ae6b1346dcdf07f2f pynvim-0.5.0.tar.gz
+"