aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyowm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyowm/APKBUILD')
-rw-r--r--community/py3-pyowm/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/community/py3-pyowm/APKBUILD b/community/py3-pyowm/APKBUILD
deleted file mode 100644
index 0aa21d3b829..00000000000
--- a/community/py3-pyowm/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=py3-pyowm
-pkgver=3.2.0
-pkgrel=1
-pkgdesc="A Python wrapper around OpenWeatherMap web APIs"
-url="https://github.com/csparpa/pyowm"
-arch="noarch"
-license="MIT"
-depends="
- py3-geojson
- py3-requests
- python3
- "
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="https://github.com/csparpa/pyowm/archive/$pkgver/pyowm-$pkgver.tar.gz"
-# Tests require valid API key
-# net required for tests
-options="!check"
-builddir="$srcdir/pyowm-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- pytest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="595e69566b5401092241ee8bd86b203080c63950b3634612c2a6096255ba76d6a5160a8f2c49204dbce54d6a1397ea954e26079aa59bee764e9ccd0d3521e60b pyowm-3.2.0.tar.gz"