aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pypeg2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pypeg2/APKBUILD')
-rw-r--r--community/py3-pypeg2/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-pypeg2/APKBUILD b/community/py3-pypeg2/APKBUILD
index 3969caa98d3..202457f9663 100644
--- a/community/py3-pypeg2/APKBUILD
+++ b/community/py3-pypeg2/APKBUILD
@@ -1,9 +1,9 @@
-# Contributor: Drew DeVault <sir@cmpwn.com>
+# Contributor:
# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
pkgname=py3-pypeg2
pkgver=2.15.2
-pkgrel=6
+pkgrel=10
pkgdesc="An intrinsic PEG Parser-Interpreter for Python"
url="https://fdik.org/pyPEG2/"
arch="noarch"
@@ -11,6 +11,7 @@ license="GPL-2.0-only"
_gitrev="43b84d987ec1"
depends="python3 py3-lxml"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pyPEG2/pyPEG2-$pkgver.tar.gz"
builddir="$srcdir/pyPEG2-$pkgver"
@@ -26,7 +27,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="f78e3b1294169167809c5fe05f2a69af2bd6c7c4c1bcbebafb4aa6b8ae6ead181a46b051e41193bc31f49c4b4fa7b1ef231d172217c11d301d0ee21d8e411b6f pyPEG2-2.15.2.tar.gz"