aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyphen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyphen/APKBUILD')
-rw-r--r--community/py3-pyphen/APKBUILD29
1 files changed, 21 insertions, 8 deletions
diff --git a/community/py3-pyphen/APKBUILD b/community/py3-pyphen/APKBUILD
index 9d5d7f37ab1..78a59f74f47 100644
--- a/community/py3-pyphen/APKBUILD
+++ b/community/py3-pyphen/APKBUILD
@@ -1,32 +1,45 @@
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer:
pkgname=py3-pyphen
_pkgname=Pyphen
-pkgver=0.10.0
+pkgver=0.14.0
pkgrel=1
pkgdesc="python-based dictionary hyphenator library"
url="https://www.pyphen.org"
arch="noarch"
license="GPL-2.0-or-later AND LGPL-2.1-or-later AND MPL-1.1"
depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
+makedepends="py3-gpep517 py3-flit-core"
+checkdepends="py3-pytest py3-pytest-cov py3-pytest-isort py3-pytest-xdist"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/Kozea/Pyphen/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-pyphen" # Backwards compatibility
provides="py-pyphen=$pkgver-r$pkgrel" # Backwards compatibility
+prepare() {
+ default_prepare
+ # disable pytest-flake8
+ # https://github.com/tholo/pytest-flake8/issues/87
+ sed -i 's/--flake8//' pyproject.toml
+}
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- py.test-3 -v test.py
+ python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pyphen-$pkgver-py3-none-any.whl
}
-sha512sums="b6d789ca6eb010c1c79b28a9a0e68620ea5600adc43111bed5dbda3cb8b3a4c8c05caa3fb44ea60b0ef4a20272f17cf5e6fe61f0d1e48038395407ff53da7a92 Pyphen-0.10.0.tar.gz"
+sha512sums="
+62fa5282d16cde7d64164610e2e2de098351d4fa9f04c6f37923d5e43f5123dbf2094561b6de4d7b5b2f92a3506164b0e915b9d1c147eb3b70352c9358d7d457 Pyphen-0.14.0.tar.gz
+"