aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pysendfile/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pysendfile/APKBUILD')
-rw-r--r--community/py3-pysendfile/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py3-pysendfile/APKBUILD b/community/py3-pysendfile/APKBUILD
new file mode 100644
index 00000000000..2bd241f6c25
--- /dev/null
+++ b/community/py3-pysendfile/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-pysendfile
+_pkgname=pysendfile
+pkgver=2.0.1
+pkgrel=7
+pkgdesc="Python interface to the sendfile(2) system call"
+url="https://pypi.org/project/pysendfile"
+arch="all"
+license="MIT"
+replaces="py-sendfile" # for backwards compatibility
+provides="py-sendfile=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="d6ee08eb251fac30c90a9ee829fd992f3620697eef2893ced5a2c6273486c3c5fd35c70962585a8d747d578817391f91c929bfeeba8c4485d52a15748229ca9c pysendfile-2.0.1.tar.gz"