aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyside6/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyside6/APKBUILD')
-rw-r--r--community/py3-pyside6/APKBUILD69
1 files changed, 0 insertions, 69 deletions
diff --git a/community/py3-pyside6/APKBUILD b/community/py3-pyside6/APKBUILD
deleted file mode 100644
index 47b3692f179..00000000000
--- a/community/py3-pyside6/APKBUILD
+++ /dev/null
@@ -1,69 +0,0 @@
-# Maintainer: Luca Weiss <luca@z3ntu.xyz>
-pkgname=py3-pyside6
-pkgver=6.3.0
-pkgrel=0
-pkgdesc="Enables the use of Qt6 APIs in Python applications"
-url="https://doc.qt.io/qtforpython-6/"
-# s390x blocked by qt6-qtdeclarative-dev
-arch="all !s390x"
-license="LGPL-3.0-only AND GPL-2.0-only"
-depends="py3-shiboken6"
-makedepends="
- cmake
- ninja
- libshiboken6-dev
- py3-shiboken6
- qt6-qt3d-dev
- qt6-qtbase-dev
- qt6-qtcharts-dev
- qt6-qtconnectivity-dev
- qt6-qtdatavis3d-dev
- qt6-qtdeclarative-dev
- qt6-qtpositioning-dev
- qt6-qtmultimedia-dev
- qt6-qtnetworkauth-dev
- qt6-qtremoteobjects-dev
- qt6-qtscxml-dev
- qt6-qtsensors-dev
- qt6-qtserialport-dev
- qt6-qtsvg-dev
- qt6-qttools-dev
- qt6-qtwebchannel-dev
- qt6-qtwebsockets-dev
- samurai
- shiboken6
- py3-setuptools
- py3-wheel
- "
-subpackages="$pkgname-dev"
-source="https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-$pkgver-src/pyside-setup-opensource-src-$pkgver.tar.xz
- fix-6.3.0-build.patch
- "
-builddir="$srcdir/pyside-setup-opensource-src-$pkgver"
-options="!check" # Tests fail
-
-build() {
- cmake -B build -G Ninja \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_SHARED_LIBS=True \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DBUILD_TESTS=OFF \
- sources/pyside6
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-
- # Install egg info
- export PATH="/usr/lib/qt6/bin:$PATH"
- python3 setup.py egg_info --build-type=pyside6
- pythonpath="$(python3 -c "from sysconfig import get_path; print(get_path('platlib'))")"
- cp -r PySide6.egg-info "$pkgdir/$pythonpath"
-}
-
-sha512sums="
-81894465199300a2b7a2afddb6b26295a46ef619ae1f55f1ebac751c0f7f65c092217f612130d1efccc7ffca1f765d1a574656a33e15e75521eca99256d913f3 pyside-setup-opensource-src-6.3.0.tar.xz
-79eca26275f1de2b796a1bd2b0177f58e7e972e13a76e19b0066397f60718acd033df0b7336f29e0f0957fb7ff1208b525b7d91a7621387361ce89b91ea945bc fix-6.3.0-build.patch
-"