aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-asyncio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-asyncio/APKBUILD')
-rw-r--r--community/py3-pytest-asyncio/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/community/py3-pytest-asyncio/APKBUILD b/community/py3-pytest-asyncio/APKBUILD
index 758986d3a15..969f81c33b1 100644
--- a/community/py3-pytest-asyncio/APKBUILD
+++ b/community/py3-pytest-asyncio/APKBUILD
@@ -1,29 +1,38 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-pytest-asyncio
-pkgver=0.12.0
-pkgrel=0
+pkgver=0.21.1
+pkgrel=2
pkgdesc="Pytest support for asyncio"
url="https://github.com/pytest-dev/pytest-asyncio"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-pytest"
-makedepends="py3-setuptools"
-checkdepends="py3-async_generator py3-coverage py3-hypothesis"
-options="!check" # doesn't find its own modules
+depends="py3-pytest"
+makedepends="py3-setuptools py3-setuptools_scm py3-gpep517 py3-installer py3-wheel"
+checkdepends="py3-async_generator py3-coverage py3-hypothesis py3-flaky py3-pytest-trio"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/pytest-dev/pytest-asyncio/archive/v$pkgver.tar.gz"
builddir="$srcdir/pytest-asyncio-$pkgver"
+options="!check" # fail for some reason
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" py.test-3
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/pytest_asyncio-*.whl
+ test-env/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest_asyncio-*.whl
}
-sha512sums="2e69bfff3f0b35cc82381b841229749d309967ce1d36972933f5bc6d5dff45934608310ed3fa1805dc38ab41bf913a881493c28d6d0e9be733b624cd2fda97d3 py3-pytest-asyncio-0.12.0.tar.gz"
+sha512sums="
+315007038d510ce876638d49d2310962f34264440452ed49f7cbdb608340bd1eb4868d529e44812a9cb5bf5dfe123c338ab2fa4c892505329820f5da15d2bb6d py3-pytest-asyncio-0.21.1.tar.gz
+"