aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-cov/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-cov/APKBUILD')
-rw-r--r--community/py3-pytest-cov/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-pytest-cov/APKBUILD b/community/py3-pytest-cov/APKBUILD
index 1f2e111ae4c..595597183b4 100644
--- a/community/py3-pytest-cov/APKBUILD
+++ b/community/py3-pytest-cov/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: TBK <alpine@jjtc.eu>
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=py3-pytest-cov
-pkgver=2.11.1
+pkgver=4.1.0
pkgrel=1
-pkgdesc="Pytest plugin for measuring coverage."
+pkgdesc="Pytest plugin for measuring coverage"
options="!check" # Requires unpackaged 'fields' module
url="https://github.com/pytest-dev/pytest-cov"
arch="noarch"
@@ -14,6 +14,7 @@ depends="py3-pytest py3-coverage"
makedepends="py3-setuptools"
#py3-pytest-xdist introduces a circular dependency
#checkdepends="py3-virtualenv py3-pytest-xdist"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/pytest-dev/pytest-cov/archive/v$pkgver.tar.gz"
builddir="$srcdir/pytest-cov-$pkgver"
@@ -22,11 +23,13 @@ build() {
}
check() {
- pytest-3
+ pytest
}
package() {
python3 setup.py install --prefix="/usr" --root="$pkgdir"
}
-sha512sums="513e89c061e926cfab718adb1a52f573abec6d67635df4ef791dc9a0e6338369c3a0771c9f2a44c5c2a17ab5a5ebc21398b4e3c525dba50724f70eea22a1c9ce py3-pytest-cov-2.11.1.tar.gz"
+sha512sums="
+d5eca8c750b6668a2b893e65d6799267d1a13eda78908880f454533a7846f1c4f94df6b5b702436e74a2ffb7912a19cae5edb6452abf3cc7c4765f187db039f1 py3-pytest-cov-4.1.0.tar.gz
+"