aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-forked/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-forked/APKBUILD')
-rw-r--r--community/py3-pytest-forked/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/py3-pytest-forked/APKBUILD b/community/py3-pytest-forked/APKBUILD
index 0f2d1e076af..cbcb30aec35 100644
--- a/community/py3-pytest-forked/APKBUILD
+++ b/community/py3-pytest-forked/APKBUILD
@@ -2,18 +2,19 @@
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname=py3-pytest-forked
_pyname=pytest-forked
-pkgver=1.3.0
-pkgrel=1
+pkgver=1.6.0
+pkgrel=2
pkgdesc="extracted --boxed from pytest-xdist to ensure backward compat"
url="https://github.com/pytest-dev/pytest-forked"
arch="noarch"
license="MIT"
depends="py3-pytest"
makedepends="py3-setuptools py3-pbr"
-checkdepends="py3-tox"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
-options="!check" # pytest issues
+options="!check" # fail with py3.11
replaces="pytest-forked" # Backwards compatibility
provides="pytest-forked=$pkgver-r$pkgrel" # Backwards compatibility
@@ -31,12 +32,15 @@ build() {
}
check() {
- local _py3ver=$(python3 -c 'import sys; print("{}{}".format(sys.version_info.major, sys.version_info.minor))')
- tox --sitepackages -e py$_py3ver
+ python3 -m venv --clear test-env --system-site-packages
+ test-env/bin/python3 setup.py install
+ test-env/bin/python3 -m pytest -v -x --tb=long
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="25d639aa43380155d7744f1d05a95e0144f5fe7dea42ff3c2bba3803a07d73b5eb008525469330c5dda14800fe4b611241691be197132f31f88f66930c3ecac0 pytest-forked-1.3.0.tar.gz"
+sha512sums="
+28fedc56fd696a4e7cf528034056849eff14094d5e7f0e94c7c477a7e91e42c08988769cf6f40d25fe8823399e552253cde2198121dd6a9e475fb6a8ce358cad pytest-forked-1.6.0.tar.gz
+"