aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-httpbin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-httpbin/APKBUILD')
-rw-r--r--community/py3-pytest-httpbin/APKBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/community/py3-pytest-httpbin/APKBUILD b/community/py3-pytest-httpbin/APKBUILD
index a82c3254550..a861076243f 100644
--- a/community/py3-pytest-httpbin/APKBUILD
+++ b/community/py3-pytest-httpbin/APKBUILD
@@ -1,25 +1,37 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-pytest-httpbin
-pkgver=1.0.0
+pkgver=2.0.0
pkgrel=1
pkgdesc="Easily test your HTTP library against a local copy of httpbin"
-options="!check" # No testsuite on pypi tarball
url="https://github.com/kevin1024/pytest-httpbin"
arch="noarch"
license="MIT"
-depends="py3-httpbin py3-six"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/p/pytest-httpbin/pytest-httpbin-$pkgver.tar.gz"
-builddir="$srcdir/pytest-httpbin-$pkgver"
+depends="py3-httpbin"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-requests"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/pytest-httpbin/pytest-httpbin-${pkgver/_/}.tar.gz"
+builddir="$srcdir/pytest-httpbin-${pkgver/_/}"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ # https://github.com/kevin1024/pytest-httpbin/issues/64
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_redirect_location_is_https_for_secure_server'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="5e890de7f90917c81ea99f5389ff955bc751a8852ced33dc16a4b950ed8966807af58e8ddee5f285e1c94254d90c07f51be619747631bb684a9123746f295d7f pytest-httpbin-1.0.0.tar.gz"
+sha512sums="
+679a51e5155cf952258cab6efb3c26fd21b8a84a73b720dc5c00b36958c11a8de27b6ea6c696c76fe4e2a85fec56a2485d3233705301f11e45cb967328700657 pytest-httpbin-2.0.0.tar.gz
+"