aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-httpserver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-httpserver/APKBUILD')
-rw-r--r--community/py3-pytest-httpserver/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/py3-pytest-httpserver/APKBUILD b/community/py3-pytest-httpserver/APKBUILD
index 5d297bf5bee..d85b00ca45a 100644
--- a/community/py3-pytest-httpserver/APKBUILD
+++ b/community/py3-pytest-httpserver/APKBUILD
@@ -1,30 +1,37 @@
# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
# Contributor: Johannes Marbach <n0-0ne+gitlab@mailbox.org>
pkgname=py3-pytest-httpserver
-pkgver=1.0.1
-pkgrel=0
+pkgver=1.0.10
+pkgrel=1
pkgdesc="Http server for pytest to test http clients"
url="https://github.com/csernazs/pytest-httpserver"
arch="noarch"
license="MIT"
depends="python3 py3-werkzeug"
-makedepends="py3-setuptools py3-pip"
-checkdepends="py3-pytest py3-pytest-runner py3-requests"
+makedepends="py3-gpep517 py3-installer py3-poetry-core"
+checkdepends="py3-pytest py3-pytest-runner py3-requests py3-toml"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/csernazs/pytest-httpserver/archive/$pkgver.tar.gz"
builddir="$srcdir/pytest-httpserver-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/pytest_httpserver-*.whl
+ test-env/bin/python3 -m pytest \
+ -k 'not test_ipv6' # Ever thought about gardening instead?
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest_httpserver-*.whl
}
sha512sums="
-e56e1accc5afcc3c5b31a7409211f22d64c9efba4c0bb43b4c42cf0ad347cb8552d98787c919befffaa2ed3ee6bee92bb2b1d70582f455c805fbfcc663fda533 py3-pytest-httpserver-1.0.1.tar.gz
+9b207d9849ea85770e879ccc71c0af816a6bb4b4cc962fd7c57ccb4d42139241161aebeae6165c8e8ef1e4c1481be4f1dc0e23460a9c8eab0eadea291d94f229 py3-pytest-httpserver-1.0.10.tar.gz
"