aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-isort/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-isort/APKBUILD')
-rw-r--r--community/py3-pytest-isort/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/py3-pytest-isort/APKBUILD b/community/py3-pytest-isort/APKBUILD
index 885d530e566..e5c62fa882f 100644
--- a/community/py3-pytest-isort/APKBUILD
+++ b/community/py3-pytest-isort/APKBUILD
@@ -1,27 +1,36 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-pytest-isort
_pyname=pytest-isort
-pkgver=1.3.0
+pkgver=4.0.0
pkgrel=0
pkgdesc="pytest plugin to check import ordering using isort"
url="https://pypi.org/project/pytest-isort/"
arch="noarch"
license="BSD-3-Clause"
depends="py3-pytest py3-isort"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/p/pytest-isort/pytest-isort-$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-poetry-core"
+subpackages="$pkgname-pyc"
+source="https://github.com/stephrdev/pytest-isort/archive/refs/tags/$pkgver/py3-pytest-isort-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD" pytest
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/pytest_isort-*.whl
+ test-env/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest_isort-*.whl
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/LICENSE.rst
}
-sha512sums="a26c5dd9428b85d1387239245c437fded84ece8148ab016de9e41be3dff72627d0e7a47176d9fa5768b366655fe7affd4f665c3d2cd6fb2f2a2e15334e1fff63 pytest-isort-1.3.0.tar.gz"
+sha512sums="
+dff28d9c402767827fc0132b3b9426ef9307e82ffbb2e7c127393102b4b77fd6436adb4baafc0239164edeeaad4648a969da5b1da6972c6678339f02367660ac py3-pytest-isort-4.0.0.tar.gz
+"